home home

shots shots

downloads files

forum forum

docs docs

wiki wiki

faq faq

Cube & Cube 2 FORUM


New release: collect edition (2013-01-04)

by eihrul on 01/06/2013 22:54, 81 messages, last message: 07/31/2013 07:00, 41094 views, last view: 05/31/2020 08:25

The highlights...

New game features - 45 new multiplayer maps, better/stronger/faster Ogro, new sounds, collect gamemodes, international character sets, faster cubescript interpreter, improved minimap.

New server features - admins/auths/masters, server-side map rotations, teamkill autokick.

New editing features - multiple water/lava/glass material types, sunlight, improved remip, copy/paste brushes.

And too much other stuff to list here, see the history page for details:

http://sauerbraten.org/docs/history.html

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages

#61: Re: Non-smooth on Mac

by suicizer01 on 01/31/2013 06:39, refers to #60

Try the command 'vscync 0'.

reply to this message

#62: Re: Non-smooth on Mac

by SanHolo on 02/02/2013 23:59, refers to #61

Perfect, that seems to solve it, thanks!

reply to this message

#63: 2013-02-03 patch

by eihrul on 02/03/2013 02:47

Another patch to fix some issues with servers...

http://sourceforge.net/projects/sauerbraten/files/sauerbraten/2013_01_04/patch_01_04_to_02_03.zip/download

* Fixes crash with server console on Windows
* Fixes crash with demo recording

reply to this message

#64: Re: 2013-02-03 patch

by Q009 on 02/03/2013 04:58, refers to #63

jeez...

reply to this message

#65: failed adding to system tray error

by TonyBB on 02/03/2013 13:30, refers to #45

I get \"failed adding to system tray\"
when starting a dedicated server with:

bin64\\sauerbraten.exe -d -i198.0.10.10 -j28785 -c16 -g50.log

and

bin\\sauerbraten.exe -d -i198.0.10.10 -j28785 -c16 -g50.log

And the server won\'t start.

reply to this message

#66: Re: failed adding to system tray error

by eihrul on 02/03/2013 13:51, refers to #65

No idea, it works for me.

reply to this message

#67: failed adding to system tray error

by TonyBB on 02/03/2013 20:01

Is there a way to disable this feature via config file or command line argument? As it was working before the update that added it.

reply to this message

#68: 2 Things I have noticed

by DJboutit on 02/07/2013 01:13

2 thing I have noticed these are bad things

Game play is way to fast slow it down like the older version it is to hard to play now

Now you can kill your own team mates lame

reply to this message

#69: Re: 2 Things I have noticed

by Q009 on 02/07/2013 04:46, refers to #68

Gameplay speed is the same
You always could kill your teammates

reply to this message

#70: Re: 2 Things I have noticed

by Bosurgi725 on 02/08/2013 06:00, refers to #68

I keep feeding the ironsnouts carrots but I can not get them to breed like they used to. Also, I now have to use scroll wheel to place blocks, lame.

reply to this message

#71: ..

by DJboutit on 02/08/2013 20:43

For me the game speed is like 2 times faster than it use to be other online games the speed is just fine

reply to this message

#72: Re: ..

by Q009 on 02/09/2013 07:24, refers to #71

Sorry, but that doesn't make any sense :P
Maybe you just went on a server which had /gamespeed 200 set?

reply to this message

#73: Re: ..

by Papriko on 02/09/2013 10:30, refers to #72

Or he played slow games for too long. When I play Minecraft for a while and no Sauer and then start up Sauer again, I'm also like "whoa :o" for a few moments because it's just much faster.

reply to this message

#74: Insane CPU usage

by lucas99801 on 03/05/2013 01:31

I'm having issues with the new version consuming 90+% of my cpu. System specs are as follows:

Athlon II X2 255 3.10Ghz (Regor)
8GB RAM
Nvidia GTX 650 (<6 months old)
Windows 7 x64

I've tried disabling ALL graphic features, putting everything to minimal that does not have the option of disabling and still no luck. The only adjustment that had any effect was disabling full screen which still resulted in 75-85% usage on sauerbraten.exe

Anyone seeing this issue or know of a fix?

reply to this message

#75: Re: Insane CPU usage

by Razgriz on 03/05/2013 02:02, refers to #74

Besides having a CPU which is likely a bottleneck for other games besides sauerbraten, chances are the uncaged framelimit is what causes the game to try to render as many frames as possible, which is easy for the GPU but taking its toll on your CPU. Try enabling vsync and also do /maxfps 60

reply to this message

#76: No Launch Window

by AtlasSteal on 03/05/2013 03:30

I've yet to report this to anybody, heck, it might already be fixed, or it could just be me, but when I click on the Sauer icon to open it, instead of getting a launch window like I used too where I could control settings, look at maps, and access my user game files, it just opens up a window that basically tells me that "Sauerbraten is an application downloaded from the internet. Are you sure you want to open it?" I can play Sauerbraten, it's just that I've even searched my whole computer for a base file, and I haven't found it. I've just wondered if this has been fixed or not. Also, I'm playing on a 10.5.8 Mac. Hope this can be dealt with. Thanks.

reply to this message

#77: Re: Insane CPU usage

by lucas99801 on 03/06/2013 01:13, refers to #75

Yeah. I'm not expecting much out of this CPU, but I've never had issues with Sauer before. I'll try the /maxfps 60 next chance I get. Is it peristent between startups? I had forgotten about the uncaged framelimit.

Sidenote: Tried this on a Thinkpad at work with an i5. Sauer consumed 80% of 2/4 cores, peaking at 60% usage across all cores. Setting maxfps to 60, dropped this to 16-20% max across all cores

reply to this message

#78: Re: No Launch Window

by HeWhoPwnsYou on 03/06/2013 01:24, refers to #76

The launch window is gone. You can bypass the message saying \\\"Sauer is downloaded from the internet\\\" by control/right clicking sauer and manually selecting open. The base folder is in /Users/YOUR_USERNAME_HERE/Library/Application\\\\ Support/sauerbraten/. To get here, you have to either cmd-shift-g and type in the file path by hand/using tab complete, or go to GO on the menu bar and select go to a folder, then enter the file path. I recommend adding the sauerbraten folder to the sidebar of the finder window. None of these are bugs, just btw.

reply to this message

#79: Re: Insane CPU usage

by lucas99801 on 03/08/2013 06:56, refers to #75

Confirming that /maxfps 60 worked for the 90% CPU issue.

CPU usage is now at 10-20%, 30-40% if vsync is enabled

Thanks again Razgriz

reply to this message

#80: ..

by Jmrbob300 on 04/04/2013 06:52

Any idea when the Ubuntu Repo is getting updated with collect? All the linux downloads I get are corrupt >.>

reply to this message

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages


Unvalidated accounts can only reply to the 'Permanent Threads' section!


content by Aardappel & eihrul © 2001-2020
website by SleepwalkR © 2001-2020
33620066 visitors requested 48420263 pages
page created in 0.037 seconds using 10 queries
hosted by Boost Digital