home home

downloads files

forum forum

docs docs

wiki wiki

faq faq

Cube & Cube 2 FORUM


New release: Justice edition...

by eihrul on 07/20/2010 08:50, 65 messages, last message: 07/30/2010 05:33, 39837 views, last view: 12/05/2022 18:34

http://cubeengine.com/files.php4

30 new maps, Inky and Captain Cannon player models, hold and efficiency game modes, vslots for editing texture properties in-game, alpha material for making transparent geometry, multi-threaded calclight, radar mini-map, and more stuff...

See changelog for more info:

http://sauerbraten.org/docs/history.html

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages

#41: ..

by MisterLombax on 07/23/2010 23:20

nuts. im having problems rendering with shaders on my mac. i can now only manage to get like 5 fps on maps like hallo while i could get like 150 fps in trooper edition. plz help. using gt 120

reply to this message

#42: Re: ..

by eihrul on 07/23/2010 23:56, refers to #41

Try redownloading the Mac package, there are bugs in MacOS X 10.5 which we tried to add a workaround for.

reply to this message

#43: ..

by TomCat39 on 07/24/2010 06:55

@Eihrul

What else other than the GPU and CPU might overheat causing a no event logged reboot?

I know it's not the GPU being that the temp at time of reboot (via speedfan logging) is only 63 C and the NVidia 230M GT has a max operating temp of 105 C. And my CPU never breaks 46 C. Not sure what the max operating temp of an Intel Core2 Duo 7450 (Tjunction 90 degrees C?) but I'm sure 46 C is not any where near that.

Would memory overheating do that? Or northbridge?

Also why would Trooper Edition stop rebooting once Toshiba released a PC Health Monitor update? Before the update I could only play a random time from 5 minutes to 25 minutes. After the update I could play for hours and never hit a reboot.

Then the reboots start once I switched to Justice. This really doesn't sound to me like an overheating issue even though the symptoms act exactly like it with no evidence to support it.

I am stumped, totally and completely stumped.

reply to this message

#44: Re: ..

by SheeEttin on 07/24/2010 10:34, refers to #43

Could be anything in hardware, if it's not software. Bad cable, bad memory, bad PSU, power blips, drawing too much power...
Of course, if it's only Cube 2, and only a specific version, it's probably not hardware...

What happens if you just uninstall this PC Health Monitor program entirely?
(Also, you installed the July 23rd patch, right?)

reply to this message

#45: ..

by TomCat39 on 07/24/2010 19:41

@SheeEttin

I thought of that and uninstalled the Monitor. Thought all was well being I played a bunch of the July 19 package without any issues. So I reinstalled July 21 thinking that did it and hit reboots. Today I installed July 23 and reinstalled the Monitor to see if installing the monitor after Sauer was the trick. Sadly no.

However I have noticed one thing. I never reboot playing instagib games (hold, ctf, team or vanilla insta). I do reboot playing regen capture (I play this a lot). I do not know if efficiancy or FFA is a problem. I don't recall a time I rebooted in either of those modes but I don't play them a whole lot or for long periods of time (mostly because there usually isn't much public play in those modes consistently).

I tested this today with the July 23rd package. I played about 3 maps of Insta Hold without issue, played 1 map of regen capture and rebooted before the round was finished.

Oh and my temps at reboot was GPU 64C, Core1 41C, and Core0 45C. I also noted that Core0 and GPU had hit these same temps a few times before in the log list. It was not the first instance of these tempuratures.

Also to note, the Health Monitor was disabled during play being I hadn't enabled it after reinstall. I'm not so sure it has anything to do with this anymore. Just weird how it worked in Trooper version.

I will try Oblivion and see if I have issues with that. I know that taxes a PC heavily and I haven't tried it on this Laptop since getting it.

I will let you all know how it goes after some solid play testing.

reply to this message

#46: Re: ..

by Zorg on 07/24/2010 21:11, refers to #45

TomCat: Let me try a shot in the dark here.

Assumption 1: You play with sound.
Assumption 2: Your Laptop has some kind of HDD damage protection thingy.
Assumption 3: This protection thingy is correlated with the Health Monitor.

Try playing without sound! (My Laptop will freeze if a certain song is played. There is a shake sensor which switches off the HDD on case of heavy shaking and obviously there is some resonance frequenzy...)

reply to this message

#47: ..

by TomCat39 on 07/24/2010 21:39

@Zorg

That's an interesting viewpoint.

Regrettably, I play via Headphone setup or piped through a standalone tuner and speakers. I don't use the laptop speakers when at home.

That would have been a short and sweet solution. But alas.... :(

reply to this message

#48: Re: ..

by JonnyStrike on 07/25/2010 00:16, refers to #47

Hi TomCat39

I believe Zorg means no sound as in game sound disabled.

With speakers on or not.

reply to this message

#49: Re: ..

by Zorg on 07/26/2010 01:22, refers to #48

Jonny, I meant the laptop speakers (or any other speakers which could activate a shake sensor accidentally). I can't imagine this happens via headphone.

Sorry it didn't help, TomCat. Hope you'll find a solution.

reply to this message

#50: ..

by TomCat39 on 07/26/2010 05:36

@Zorg - Thanks Zorg, I read your whole post so knew exactly what you were talking about. I've activated that HD vibration sensor a few times so am intimately familiar with it.

@Eirhule - Interestingly enough, with the July 23, 2010 package I just had a win32 exception error. I have a jpg snippet of it but am not sure where to post it so you can get your debug info.

I was playing Insta CTF for about 4 or 5 maps when it occurred.

Please let me know where I can send the jpg snippet. Much easier and faster than me trying to transcribe all the text to here (no cut and paste from images).

reply to this message

#51: ..

by TomCat39 on 07/26/2010 05:37

*Eihrule - Sorry for the typo in your name.

reply to this message

#52: razzlefrack#@^%$#@%^$

by TomCat39 on 07/26/2010 06:31

Well..... I really don't want to stop playing Sauerbraten. This is starting to get to me.

Played a bit of regen and disconnected after a bit, 2 partial maps rounds. Came in on one, left before second was over. Started playing some Insta CTF being I'd never hit a problem (except the exception just a bit before with water and sdl I think) and not even 5 minutes into the round of insta ctf, reboot.

Yet I can play Oblivion for an hour solid and that is a WAY more intensive engine last I knew. And it plays Oblivion on much higher settings and smoother than my old 7800 GS CS AMD XP 2800+ machine ever did. Yet that old machine never had problems With Cube 2 while this machine does.

Is there a way to have Sauer log everything during play? Maybe then we might see what it's chocking on or at?

Speedfan reports all tempuratures to be within spec.

reply to this message

#53: Re: ..

by eihrul on 07/26/2010 07:20, refers to #50

http://imgur.com/

reply to this message

#54: Re: razzlefrack#@^%$#@%^$

by Megagun_ on 07/26/2010 15:30, refers to #52

Hmm, try disabling soft shadows (choosing for blob shadows instead) in the gfx tab. I know that they're giving me some problem with screen tearing and unstability on my FireGL V5250 card; they might give you problems, too.

reply to this message

#55: ..

by TomCat39 on 07/26/2010 16:25

http://imgur.com/Akhal.jpg

@Megagun - I'll give that a shot. Thanks for the suggestion.

reply to this message

#56: List of suggestions/fixes/improvements/additions

by Megagun_ on 07/26/2010 19:45

Here's a quick list of non-praise (because everyone knows that the new defaults for /newmap are awesome, and that f9 in editmode is epic win, right!?) comments I have regarding the current release. These are mostly related to new features, plus things that have been bugging me a lot. These are sorted (as far as I can tell) by easiest-to-implement first.

-----

[FIX] Hitting F2 in editmode to go to the texture browser, and then hitting escape opens the main menu, rather than closing the texture browser as is expected. All other menus (like F3/F4 in editmode) *do* close when hitting escape.

[IMPROVEMENT] `/bind a` should echo the command bound to a (echo (getbind a)), and `/bind a ""' should clear it, just like in the Source engine. Currently, `/bind a` clears the bind.

[ADDITION] `clearlightmap` command to clear the lightmap. Currently, there doesn't seem to be a way to completely clear the lightmap neatly (I think you'd have to write a script to copy all lights, remove all lights, recalc lightmap, then paste them again).

[FIX/IMPROVEMENT] Two texture rotation configurations are missing in `texrotate` and `vrotate`: "90 degrees rotation + x flip" and "90 degrees rotation + y flip".

[ADDITION] `copytexplusparams` (or something) command to copy the selected texture plus it's parameters (vrotate, voffset, vsize, etc). Also, a `pastetexplusparams` command to paste the copied texture.

[ADDITION] `allvfaces` command that mimics the `allfaces` command. "allvfaces 1" should make it so that any vcommand (vrotate, voffset, vscale) should be applied to *all* faces.

[ADDITION/IMPROVEMENT] Shift+clicking on a texture in the texture browser should be a short way to use the "vlayer N" command, so that you can easilly set the texture to paint in blendmode with without having to guess what number it is, or using F9 to figure that out.

[ADDITION] Ability to spawn bots (like in Bot-DM) in SP mode with an optional parameter to set the model directory. Alternatively, a "setmonster N *" command to set monster N's weapon type, model directory, etc.

[IMPROVEMENT] Textures with an alpha channel should be blended with nicely, so that you can create blood splatters on the wall nicely (http://www.rockpapershotgun.com/images/april08/sshock2d.jpg). Unfortunately, this would probably require horizontal painting of blendmaps which you're currently not able to do.

reply to this message

#57: Re: ..

by SheeEttin on 07/26/2010 20:45, refers to #55

Pending a real response from eihrul, try turning off water reflections. It looks like that's where it's crashing.

reply to this message

#58: Re: List of suggestions/fixes/improvements/additions

by Hirato Kirata on 07/27/2010 04:57, refers to #56

1) The texture menu is not a regular menu, it's hardcoded. In short cleargui does not affect it. if you want, you can add if $editmode [showtexgui -1] into the bind for ESC

2) at the moment, you can use /echo (getbind a) to echo the current bind (as an example)

3) I've so far encountered 2 ways of doing this. the first is to do the equivalent of /sendmap and /getmap, and the second is to start calculating lightmaps and to cancel immediately

5) /gettex will place it at the top of your texture list (Y + scroll). Using standard copy paste procedures will also move the correct texture slots around. You can also use /replace to replicate the edit on all matching textures (ie changing a 5 to 20 and then invoking replace will replace all 5's with 20's)

6) allfaces already has this effect

7) that is actually a very good idea, a method to apply the texture as a layer over the selection rather than applying it onto the geometry

9) to have any alpha blending, you first need to add alpha material. you can then use /valpha 1 to make the surface completely opaque while keeping alpha blending active.
Also to do that ideally, you'd need to use a texture with the writing already there. This also means using a mapmodel would be a significantly better choice.

reply to this message

#59: ..

by TomCat39 on 07/27/2010 05:42

I'm happy to annouce that with Soft Shadows turned off (Blob Shadows enabled) and turning off water reflections, that I was able to play for over an hour without issue.

I will keep play testing but I think that the soft shadows is probably the major factor, thank you for that suggestion Megagun.

It's strange that a DirectX 10.1 GPU would have problem with soft shadows but alas... So does the fireGL though so maybe something is slightly askew there... I dunno, I'm rather happy that I can play consistently again, or so I think :) Time will tell.

reply to this message

#60: Re: ..

by eihrul on 07/27/2010 06:56, refers to #59

The OpenGL drivers on your hardware could just be randomly/catastrophically buggy, which is par for the course with ATI + OpenGL.

reply to this message

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages


Unvalidated accounts can only reply to the 'Permanent Threads' section!


content by Aardappel & eihrul © 2001-2022
website by SleepwalkR © 2001-2022
48298447 visitors requested 65032414 pages
page created in 0.011 seconds using 10 queries
hosted by Boost Digital