home home

shots shots

downloads files

forum forum

docs docs

wiki wiki

faq faq

Cube & Cube 2 FORUM


Bug Reports

by eihrul on 09/03/2008 01:41, 1155 messages, last message: 11/28/2018 17:17, 492470 views, last view: 12/09/2019 16:19

Please post your bug reports in here.

With your bug report, please submit the following information:

1) OS: Your operating system, i.e. Linux, Windows, or otherwise and what version you are using.

2) 3D card: The 3D card you are using. If you do not know, this is printed on the "Renderer:" line in the console when Sauerbraten starts up.

3) The edition of Sauerbraten you are using, i.e. Assassin edition, CVS as of a particular date, or otherwise.

4) Error information: If you are on Windows, a pop-up message showing filenames and line numbers should show up when Sauerbraten crashes; if possible, post a screenshot or a copy/paste of this. If on Linux, post a log of the startup info from the console, including relevant errors or any info you might have discovered. If on MacOS X, please post the crash log if applicable.

5) A description of the problem and how to reproduce it. Please give as much detail as possible on how someone can recreate the problem, in as certain terms as you can. If someone else can't reproduce the problem, it is unlikely he can fix it or tell you what is wrong.

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages

#154: Re: Editing surprise.

by Stotto on 04/05/2009 05:56, refers to #151

This rather lovely bug is also present in the SVN version.

reply to this message

#155: Re: Two graphical glitches

by eihrul on 04/05/2009 23:56, refers to #147

Fixed the water surface issue.

reply to this message

#156: Re: Two graphical glitches

by Maxime -Max of S2D- Lebled on 04/06/2009 10:46, refers to #149

Swap rendering priorities in and out of water?

reply to this message

#157: ..

by [SKY]Luziferius on 04/09/2009 15:59

Hi,
for all who have the mouse-probleme and cant exit sauerbraten... simply try '/quit' ^^
-----
1) Linux(Ubuntu 8.04, 64bit)

2)ATI HD4870 with fglrx(latest version) (works fine, no problems with it)

3)CVS 04/06/2009

4)$ ./sauerbraten_unix
Using home directory: /home/thomas/.sauerbraten

init: sdl
init: net
init: game
init: video: mode
Stencil buffer not supported - disabling
init: video: misc
init: gl
Renderer: ATI Radeon HD 4800 Series (ATI Technologies Inc.)
Driver: 2.1.8543 Release
Rendering using the OpenGL GLSL shader path.
init: console
init: gl: effects
init: world
init: sound
init: cfg
init: mainloop
read map packages/base/metl2.ogz (0.0 seconds)
Elsinore by metlslime
game mode is coop edit
Cooperative Editing: Edit maps with multiple players simultaneously.
Segmentation fault

5)
I switch to edit-mode and fly through ents(ammo, light, teleporters... whatever) and sauerbraten crashes in most cases.

reply to this message

#158: Problem dropping out of full screen, loosing mouse & kbd

by georgew on 04/09/2009 18:02

I have a fresh installation on an Ubuntu 8.04 LTS system (that is up to date with all OS updates). A dell 530 with 4g of ram.

The game loads and runs fine, and looks great, using only the motherboard video.

I'll be in the game for about 10 minutes, when it will suddenly drop out of full screen mode. The game is still running, but it is holding onto the keyboard and mouse still, but not accepting keystrokes, and only slightly responsive to the mouse.

This is sort of like a lockup, in that I no longer have control of the system... But the game appears to still be running.

Is there a way to get it to release the keyboard and mouse? If so, I could hit the button to go back into fullscreen mode, and continue gameplay.

The game in unplayable in this state.


Thanks!

reply to this message

#159: Re: Problem dropping out of full screen, loosing mouse & kbd

by MovingTarget on 04/09/2009 20:19, refers to #158

You're not, by any chance, using Compiz? In other words, are you using desktop effects? If so... install the Compiz-Fusion Icon and switch over to the Metacity WM whenever gaming.

reply to this message

#160: ..

by [SKY]Luziferius on 04/11/2009 22:14

i added the line
killall compiz.real
at the top of the sauerbraten_unix script, so it kills compiz before starting sauerbraten... its not a nice way but it works
when the mouse doesnt want to work properly, try /quit to quit the game

reply to this message

#161: Re: ..

by SheeEttin on 04/12/2009 06:57, refers to #160

Try "metacity --replace" at the top and "compiz --replace" at the bottom.

reply to this message

#163: Installer

by jondaven on 04/15/2009 04:32

When ever i try to install I get a message that says the installer is corrupt or missing. I have tried a lot and I keep getting the same message.

reply to this message

#164: Re: Installer

by MeatROme on 04/15/2009 14:21, refers to #163

There's only one thing you can try : re-download .. probably best to use a different mirror than the one you got that file from ... or your issue lies with your system being compromised (read: virus/malware infected).

See the sf.net wiki for details on mirrors and how to select them: http://apps.sourceforge.net/trac/sourceforge/wiki/Mirrors

reply to this message

#165: Sauerbraten Crashes on Start Up

by 3lchucho on 04/19/2009 23:34

I am using Mac OS X 10.5.6 with Sauerbraten CTF edition (June 17 2008). When I start Saurbraten, the setup screen (asking for resolution, shading, etc) works fine. When i click start, the game starts loading, and then after about 5 seconds, it closes and crashes. This happens every tim i try to open it. Please help me.

reply to this message

#166: Message censored by administrator

by ZOMGACCOUNT on 04/20/2009 00:18

#167: Re: Sauerbraten Crashes on Start Up

by a~baby~rabbit on 04/20/2009 01:03, refers to #165

Please read the start of this thread about error reports - you need to provide more information

reply to this message

#168: ..

by LedIris on 04/20/2009 13:18

The skybox for lostinspace is missing in the SVN.

reply to this message

#169: Re: ..

by LedIris on 04/20/2009 13:42, refers to #168

NVM, It isn't.

reply to this message

#170: greyscale skyboxes

by $k!llz on 04/21/2009 01:52

um im in winxp, ati x1600pro, aMD 3800+.

the skyboxes for about 50% of the maps are ugly and gray. im in ctf edition, and it never used to do it. i was messing around with textures, so maybe thats why. any halp?

reply to this message

#171: Re: greyscale skyboxes

by MeatROme on 04/21/2009 08:52, refers to #170

http://cube.wikispaces.com/FAQ#toc4

reply to this message

#172: Re: Editing surprise.

by Stotto on 04/28/2009 20:49, refers to #151

Did anything happen with this ? Is anyone even going to acknowledge that the bug exists ?

reply to this message

#173: Re: Editing surprise.

by SheeEttin on 04/28/2009 21:11, refers to #172

It's been present since about forever.
It's just some funky subdivision, and, I think, a limitation of the engine.
Everyone just deals with it.

reply to this message

#174: Gamma drift

by Stotto on 04/28/2009 21:20

When I first installed Sauerbraten, it was correctly lit at an in-game gamma of 110, but as time has gone on this has needed to be set higher and higher and is now 200. I've seen the same thing on another computer, and there it seemed to be related either to alt-tabbing, or to Sauerbraten crashing or being killed.

The current computer runs XP home, and suffers from an Intel 82865G graphics controller.
CTF edition from Sourceforge, on March 10.

reply to this message

Go to first 20 messagesGo to previous 20 messages    Board Index    Go to next 20 messagesGo to last 20 messages


Post a Message

Username

Email

Subject

Body

5 multiplied by 1 is?


content by Aardappel & eihrul © 2001-2019
website by SleepwalkR © 2001-2019
32633777 visitors requested 47222382 pages
page created in 0.105 seconds using 10 queries
hosted by Boost Digital