home home

shots shots

downloads files

forum forum

docs docs

wiki wiki

faq faq

Cube & Cube 2 FORUM


Bug Reports

by eihrul on 09/03/2008 01:41, 1155 messages, last message: 11/28/2018 17:17, 487831 views, last view: 11/13/2019 18:52

Please post your bug reports in here.

With your bug report, please submit the following information:

1) OS: Your operating system, i.e. Linux, Windows, or otherwise and what version you are using.

2) 3D card: The 3D card you are using. If you do not know, this is printed on the "Renderer:" line in the console when Sauerbraten starts up.

3) The edition of Sauerbraten you are using, i.e. Assassin edition, CVS as of a particular date, or otherwise.

4) Error information: If you are on Windows, a pop-up message showing filenames and line numbers should show up when Sauerbraten crashes; if possible, post a screenshot or a copy/paste of this. If on Linux, post a log of the startup info from the console, including relevant errors or any info you might have discovered. If on MacOS X, please post the crash log if applicable.

5) A description of the problem and how to reproduce it. Please give as much detail as possible on how someone can recreate the problem, in as certain terms as you can. If someone else can't reproduce the problem, it is unlikely he can fix it or tell you what is wrong.

   Board Index    Go to next 20 messagesGo to last 20 messages

#1: ..

by MovingTarget on 09/04/2008 14:54

Heh, I never thought I'd be posting here, but oh well...

1) Windows XP SP3
2) nVIDIA Quadro FX 360m
3) Sauerbraten CTF Edition
4) Immediately after I start Sauerbraten, a popup with the dreaded words "Sauerbraten Win32 Exception: 0xc0000005 [0x0]" pops up. Here's a link to a screenshot: http://img58.imageshack.us/img58/9946/sauerscreenshotev6.jpg
5) I'm afraid to say that I don't do anything special to make it happen... I just start the game

The strange thing is, I've never had anything like this happen before, ever.

reply to this message

#2: Re: ..

by Quin on 09/05/2008 02:35, refers to #1

Does deleting config.cfg and init.cfg help, or a fresh install for that matter?

reply to this message

#3: Re: ..

by MovingTarget on 09/05/2008 23:43, refers to #2

A fresh install fixed it.

reply to this message

#4: Plz send default waterfall texture

by 00Hugo00 on 09/07/2008 14:28

Can you send default waterfall texture ?

I hva odwnloaded an other texture
and waterfall refract and env map downt works !

Version : CTF edition
Windows vista 32 sp1

Nvidia geforce 8600gt

2 gb of ram

reply to this message

#5: Re: Plz send default waterfall texture

by eihrul on 09/08/2008 00:56, refers to #4

It sounds like you need to try installing OpenGL drivers for you video card. Go to http://nvidia.com and make sure you have the latest ones installed.

reply to this message

#6: lost cross hairs

by Bushpig on 09/11/2008 09:43

i have enjoyed playing Sb for a few weeks, went to muck around editing a map and when i went back to play multiplayer i had lost the cross hairs of my weapon. pretty hard to hit what your aiming for without them!! what have i done? how do i get them back. the cross hairs aren't there for the single player game either.

Desperate to get back to fragging. can someone help?

reply to this message

#7: Re: lost cross hairs

by Quin on 09/11/2008 10:31, refers to #6

http://cube.wikispaces.com/FAQ#toc4

reply to this message

#8: Re: lost cross hairs

by eihrul on 09/11/2008 17:45, refers to #6

Type the following from the Sauer console:

/hidehud 0

reply to this message

#9: Re: lost cross hairs

by eihrul on 09/11/2008 17:46, refers to #8

If that fails, as a last resort remove your config.cfg (this will delete all your settings). Hopefully that would reset anything you accidently did.

reply to this message

#10: Re: lost cross hairs

by Bushpig on 09/12/2008 09:12, refers to #9

it worked like a charm. You are a legend, thanks!

look out boys and girls, bushpig is locked and loaded.

reply to this message

#11: Sauerbraten Win32 Exception

by Sarcasm on 10/03/2008 00:38

1)Windows XP SP3
2)GeForce FX Go5200/AGP/SSE2 (Its for a Dell laptop, I can't update the driver)
3)Sauerbraten CTF Edition
4)
C:\Program Files\Sauerbraten>bin\sauerbraten.exe -r
init: sdl
init: enet
init: video: mode
init: video: misc
init: gl
Renderer: GeForce FX Go5200/AGP/SSE2 (NVIDIA Corporation)
Driver: 1.5.2
WARNING: No framebuffer object support. (reflective water may be slow)
WARNING: Non-power-of-two textures not supported!
Rendering using the OpenGL 1.5 assembly shader path.
init: console
init: gl: effects
init: world
init: sound
init: cfg
init: localconnect
init: mainloop
read map packages\base\metl4.ogz (0.3 seconds)
Mining Station by metlslime
game mode is ffa/default
Sauerbraten Win32 Exception: 0xc0000005 [0xd4]


Sauerbraten Win32 Exception: 0xc0000005 [0xd4]
5)I start Sauerbraten, it loads some textures and it "recalculate geometry" (or something along those lines) then a little bit after "met|4" starts it a message comes up and says, "Sauerbraten Win32 Exception: 0xc0000005 [0xd4]" then closes. Assault Cube works perfectly on my computer.

reply to this message

#12: crash on win xp sp2

by CrashTester on 10/07/2008 16:45

Installed the Sauerbraten on my laptop Dell Vostro 1700 with WinXP SP2 (32 bit) with 3Gb RAM and Mobile Intel 965 Express video chipset (driver 6.14.10.4864). The game starts just fine with default configs, I can change video settings, but when I make 4-5 steps on the map (with or without video changes) - the game stops responding and freezes without crash report, but OS is still going without a crash. I have the latest video driver that Intel offers for this laptop.

This is console output:

D:\\\\Demos\\\\Sauerbraten>bin\\\\sauerbraten.exe -r
init: sdl
init: enet
init: video: mode
init: video: misc
init: gl
Renderer: Intel 965/963 Graphics Media Accelerator (Intel)
Driver: 1.5.0 - Build 6.14.10.4864
WARNING: No framebuffer object support. (reflective water may be slow)
WARNING: No texture rectangle support. (no full screen shaders)
WARNING: Non-power-of-two textures not supported!
WARNING: Disabling shaders for extra performance. (use \\\"/shaders 1\\\" to enable sh
aders if desired)
Rendering using the OpenGL 1.5 fixed-function path.
init: console
init: gl: effects
init: world
init: sound
init: cfg
init: localconnect
init: mainloop
read map packages\\\\base\\\\metl4.ogz (0.4 seconds)
Mining Station by metlslime
game mode is ffa/default

reply to this message

#14: Re: crash on win xp sp2

by J.C. Denton on 10/08/2008 01:29, refers to #12

The driver for your Intel IGC is not up to date.
Download the new one from here:

http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2800&OSFullName=Windows*+XP+Professional&lang=eng&strOSs=44&submit=Go!

reply to this message

#15: ..

by NIm on 10/13/2008 06:03

So I'm running linux, and I download ctf sauer for linux. But most of the content is missing. I think some directories are missing, including bin_unix. src exists, and I've compiled and run fine, but all the sound, and some of the maps are missing, including the default map.

Did somebody corrupt the archive before upload?

reply to this message

#16: Re: ..

by jbuk2k7s cookie has gone on 10/13/2008 11:08, refers to #15

Make sure to download the whole thing, not just the patch for the main install.

http://downloads.sourceforge.net/sauerbraten/sauerbraten_2008_06_20_ctf_edition_linux.tar.bz2?modtime=1214027432&big_mirror=0

http://downloads.sourceforge.net/sauerbraten/patch_2008_07_11_linux.tar.bz2?modtime=1215808509&big_mirror=0

So both of those are needed.

reply to this message

#17: thanks, i got it

by NIm on 10/15/2008 01:53

I had a retarded package manager. It was trying to read the .bz2 as a .gz Didn\'t figure those formats for ebing that compatible!

reply to this message

#18: Glibc

by baby_1 on 10/16/2008 16:16

Please see this link you know whats my problem

http://www.g4g.it/forum/viewtopic.php?f=2&t=2112

reply to this message

#19: Re: Glibc

by SheeEttin on 10/16/2008 22:34, refers to #18

No, we don't know your problem. Especially because the forum you linked to isn't working right now.

Please read the topic post and try again.

reply to this message

#20: Glibc

by baby_1 on 10/17/2008 15:28

yesterday when i use this game in single mode it taked few minutes and i restarted my computer manualy , after that when i wanta to play this game in single mode this game show me this error(before yesterday this game work properly)

new Link(picture included)
http://i38.tinypic.com/2yotq3o.jpg

i remove and install game and the libraries( game and linux rpms) but it dosen't work agian(when this error hapen my mouse doesn't work too)

please hep me

reply to this message

#21: Intel GMA 3100

by onanymous on 10/17/2008 17:15

OS: Linux 2.6.24-19 (Ubuntu Hardy)
3D Card: Intel GMA 3100
Edition of Sauer: CTF
The problem is that when I look onto wall, my VCard probably renders all the objects behind the wall, what causes slowdown. I can't see those objs, but slowdowns are the same as slowdowns, when I look onto those objects:

(I)
=========wall===========
object1 object3
object2 object4
~8fps

(I)
object1 object3
object2 object4
~8fps

What can I do to prevent it? Is it only Ubuntu bug or it's bug in Sauer engine or my graphics driver? If so, what can I do to prevent it?

Thx in advice

reply to this message

   Board Index    Go to next 20 messagesGo to last 20 messages


Post a Message

Username

Email

Subject

Body

8 times 2 =


content by Aardappel & eihrul © 2001-2019
website by SleepwalkR © 2001-2019
32483500 visitors requested 47053849 pages
page created in 0.048 seconds using 10 queries
hosted by Boost Digital