home home

downloads files

forum forum

docs docs

wiki wiki

faq faq

Cube & Cube 2 FORUM


Sauerbraten - stereo or mono music?

by _Fanatic on 05/02/2006 23:25, 13 messages, last message: 08/08/2006 04:23, 1611 views, last view: 08/03/2022 01:51

I had two reports that the music I did for Sauerbraten (called Two Minute Warning) was playing only on one channel (left or right). The OGG files are stereo files and play correctly in Winamp.

I haven't been able to test this yet, but just curious if others have noticed this. I don't know if it's with Windows only or other OS builds, or a certain sound card.

   Board Index   

#1: its

by Aardappel_ on 05/03/2006 01:37

certainly coming out of 2 speakers for me.

reply to this message

#2: Re: its

by nieb on 05/03/2006 03:39, refers to #1

The song comes out of both speakers, but your getting the same signal for both speakers. (not true stereo sound)

reply to this message

#3: ..

by makkE on 05/03/2006 03:51

Same here. They do come from both speakers, but itīs mono. In winamp they are stereo.
They sound a lot rougher and more atmospheric in stereo.

reply to this message

#4: Re: ..

by Aardappel_ on 05/03/2006 04:24, refers to #3

weird. sounds like it could be a problem with the code, but we're running SDL_Mixer in stereo mode (as you can hear from the gameplay sounds), and there's no options to play oggs to affect that. So no idea why it would choose to use mono.


reply to this message

#5: Re: ..

by _Fanatic on 05/03/2006 05:39, refers to #4

What if music is dedicated to one channel? Maybe SDL_Mixer is setup for stereo, but if music is only set for one sound slot/channel, it would be downmixed to mono possibly? (just a non-programmers guess)

reply to this message

#6: Re: ..

by Aardappel_ on 05/03/2006 07:42, refers to #5

its definitely a bug in SDL_mixer on windows, as fmod on windows and SDL_mixer on linux both give stereo sound. I can't switch back to fmod however as it doesn't support panning while a sound is playing.

I may switch to using fmodex as that does easy 3d sound out of the box, and presumably fixes all problems.

reply to this message

#7: Re: ..

by Passa on 05/03/2006 09:46, refers to #6

Wekk, just as an added note to sounds, I find that if there are too many sounds playing at once (like multiple rifle shots in instagib), sometimes my shots will not make any sounds, almost as though there are not enough sound channels.

reply to this message

#8: Re: ..

by drian@firm05 on 05/03/2006 11:27, refers to #7

Yes, the slots are limited to avoid huge sound bursts.

reply to this message

#9: Re: ..

by Backlash on 05/03/2006 15:22, refers to #6

why don't use OpenAL ?

reply to this message

#10: ..

by absinth on 05/03/2006 21:42

>why don't use OpenAL ?

+++
it's open source and it's included in linux and mac os x 10.4 by default

reply to this message

#11: Re: OpenAL

by Eivets on 05/05/2006 00:00, refers to #10

I have used OpenAL successfully in my projects. The API is quite easy and it works good. Older versions had the problem that it won't stop playing when the program crashed, really annoying!!! But that has been fixed.

reply to this message

#12: ..

by djRobbieF on 08/06/2006 18:40

Has anyone checked to see if the particular sound file in question was compressed using LC-Stereo? (Low-complexity stereo). Some programs will not interpret LC-Stereo signals and will play them back as mono.

reply to this message

#13: Re: ..

by CrazyTB on 08/08/2006 04:23, refers to #6

> its definitely a bug in SDL_mixer on windows...

Have you filed a bug report for sdl_mixer project?

reply to this message

   Board Index   


Unvalidated accounts can only reply to the 'Permanent Threads' section!


content by Aardappel & eihrul © 2001-2022
website by SleepwalkR © 2001-2022
45663323 visitors requested 61685645 pages
page created in 0.007 seconds using 10 queries
hosted by Boost Digital